Graph data update issue possibly introduced in 3.106

After updating to 3.106 it appears a graphical bug was possibly introduced in the latest update. Noticed it a few days ago but waited until I’d rebooted the phone a few times to document what I’m seeing.

I’m going to attach 2 pictures (I hope, first time) of screenshots taken ~7 hours apart. First one shows the graph at top of screen drawn completely. The second will show it ~7 hours later and it’s only about 20% filled from left to right.

I also opened it a few times along the way (6pm and 8pm perhaps…) to see if the bug appeared and it hadn’t. It seems to appear after ~7 hours or more. I noticed it first upon waking after checking the night before sleeping.

It redraws in a microsecond upon touching the screen so it doesn’t appear to be a lack of data.

Perhaps others are experiencing this? I’m using the NOAA GFS data. Im able to recreate the issue.

I haven’t uninstalled/reinstalled, nor done an actual timed and monitored bug hunt. Wanted to see if anyone else can recreate this before I spent a lot of time on it only to find out its something here.


@Kevin how do you recreate the issue? Do you leave App running continuously or do you close it and open it. I myself haven’t noticed it would like to see if I can do it as it wii help. Do you have debug loging enabled? If so send it to @duane and describe issue.


Hi Brian,

I have a widget which is how I open the app. I close the app by just backing out of it.

Recreation is as simple as opening the app, seeing the screen and graph correctly, backing out, and waiting 7 or more hours. As indicated, I was able to recreate the issue even with opening the app a few times at roughly the 2 hour mark and 4 hour mark with no ill effects, but once it made it past 7 hours it appeared.

I havent debugged this further as I indicated because I haven’t confirmed anything via a measured test and don’t want to bother Duane with a phantom bug that may exist on my system only. If you can recreate this then I’ll go ahead and begin a debug session and some measured parameters. Otherwise I’ll try some things here; uninstall/reinstall, etc.

2 additional data points:. Upon awakening today, I opened FlowX and it showed a full graph for a nanosecond then removed ~75% of the right side. Closed, opened and graph is complete. O touching the interface required.

I am using NOAA HRRR now which I switched to after posting yesterday just to see if it was limited to 1 data source. It’s not.

I also just forced stop, cleared the app cache, and restarted it, hoping to clear any issue should it be a local thing. I’ll know in about 7 hours. :wink:

Let’s see if you can recreate this thing and we can go from there, thanks for the assist.


Hello Kevin
I open the app at various times have not seen this issue however I open the app via the icon I added the widget just now and will not click it tell 9pm pst to see if it happens. Will post with results.


Hi Brian,

Perfect, thx. May be worth while to try the straight up 7+ hour wait as that seems to be the amount of time required. Maybe wait 8 hours just to be sure. Also be sure not to interface with the app as any touch will restore the graph.

Open using widget/close/wait 8 hours/open again using widget. That recreates it every time here. I’ll be back late tonight to post my results after having cleared app cache/force close/open via widget/close.

Disclaimer for all: this is a very minor bug that may not exist anywhere but here. I thought it was noteworthy as it’s behavior I’ve not seen prior to this 3.106 release.


Hi Kevin,

Sorry for the slow reply.

Do you have a widget that 3 days long? What could happen is that overnight the widget it downloading 3 days worth of new data, then when you open the app in the morning, it draws that 3 days of data then proceeds to download the remaining data up to 10 days.

What I didn’t understand from your description is whether the app draws the compete graph after a few seconds (ie., after the data downloads) or weather you have to reopen the app?

Cheers, Duane.


Heya Duane!

No worries at all! This is not a big deal and I wanted to make sure it’s not something just on my system before I bothered you beyond posting here for some general input from genpop. I’m sure you’re busy.

Indeed I do have it set to 3 days, good call. It doesn’t appear to be a download data thing though, but it very well could be. The reason I think it’s not is that (and answering the question you had) is because any touch immediately draws it, there is absolutely no delay. Only a log could show this so I did go ahead and turned on debug logging after answering Brian above.

I opened it last night before going to sleep, had a full graph. This morning, opened it and it flashed up a complete graph, and in a fraction of a second, redrew the graph portion (maybe the whole screen but no obvious event to catch my eye that quickly) to about 3 days again .

I cleared app cache and reopened it earlier today and going to leave it until 10pm PST here or so (8+ hours closed).

I will jump back in then and if I can still reproduce the issue I’ll send along the debug log as Brian suggested so you can have a look.

Sorry for the cut short post “Indeed”, on my screen the Save Edit button is so close to any edit slider I thumbed the button. D’OH!!


Just doing some coding deep in the internal. It’s dark and I hardly recognise anything :slight_smile:


Did you have a 3 day widget?


Lol! Sorry, explained the bizarre short post above. I must have looked like a madman. :crazy_face:


Hahah, I know that feeling! Weekends in the server farm: enter on Friday, leave on Sunday

Gotta get a glimpse of the sun occasionally.

1 Like

Ok, it sounds like the graph isn’t being redrawn after a download for some reason???


I’ll keep and eye out for the same symptoms on my phone.


Ahhh, a background download! And for whatever reason it seems to require either input, or a close/open event, to redraw the full 10 days.

I’m in the 8hr waiting period at the moment, but once that is done and if I can reproduce the issue I’ll change the widget to 5 days before going to bed and see if that portion is related somehow in the morning. Id presume that if it was related then the next incident would only draw half the 10 day graph.

I’ll be back tonight though, maybe Brian will be able to produce it as well.

Gotta say, the hardest part here is not clicking the widget and opening FlowX, I’m a bit addicted. :laughing:


@Kevin I wasn’t able to produce the is but I will try again tomorrow start from a fresh device startup will definitely post again with results. Hope You and @duane Have a Great Weekend :slightly_smiling_face:


Hi Brian, thanks for giving it a shot, you too have a great weekend my friend!

1 Like

Ok, so I opened it at at 10pm and it happened again.

I’ve sent Duane a debug log. Going to set widget to 5 days and check it in the am.

I noticed on the 10pm open that it was complete WHILE it was downloading data (countdown wheel in upper right) and as soon as it finished it redrew the graph with the same “3 day” anomaly but I didn’t get a screen shot.

Edit:. Just opened it again 5 mins later and it downloaded a much smaller data payload, redrew, and anomaly again. Screen attached. Off to set 5 day widget.

Too big to upload, but probably not needed. Suffice it to say it’s the same thing.

1 Like

This is new for me to.
It can be easily replicated by adding a new place or switching.

The data download completes and the graphs (only) remain blank.

You’ll see in the screenshots the app interactions you can have which do not resolve the blank graph.

Two interactions do resolve the blank graph:
Timescale or main screen redraw. Squish it @duane

1 Like

Retesting today to see if I can replicate @Kevin’s issue as far as @FlowxLloyd I’ve tried adding a single to multiple locations graphs fully load tried 3 to 10 days on new locations added graphs still fully loaded. Will report back in 8hrs on Eric’s test. I’m using LG X Style Android ver. 6.0.1


Only issue I noticed is when I add new location for example I add Hawaii put lactation to show conditions in Hawaii then if I add another location like Berlin it renames it as Hawaii. so whatever last location shown on map is what the newly added location is named. Crazy how 3 different people having different issues.