Android widgets not loading since 3.266

Hello, I got update to beta 3.266 last night and since then widgets are blanks and do not load. Tapping them does nothing.
I have re-added a widget from scratch, same result.

OnePlus 5 running Android 10.

1 Like

Ignore, should have tried rebooting phone first, that solved it.


Hi @h5h5g5,

Thanks for the post. Were you the guy on the reviews? Thanks if you were.

In any case, your report is useful. I think the widget isn’t updating after an update because the update kill the scheduled job to update the app. But when you reboot, it restarts the scheduled job.

I’ll look at adding a trigger to reschedule the widget update after an app update.

Cheers, Duane.


@duane, yes, that was me with the private feedback.

1 Like

make sure the app can run in the background. I noticed if the app is optimized, it will not show in the widget. you will need to set the app to run in the background (app settings -> battery -> allow background activity). do not put in deep sleep list. and you will need network connection available (either wifi or mobile). noticed if there is no network connections available, the widget will not show up. also when rebooting, if widget does not appear, you will need to open the app and close it to force update the widget.

1 Like

Thanks for the detailed observations.

Widgets have been a right pain since all the Android battery optimizations. I have written on my to-do list “Maybe start a new widget module”.

I’m thinking of rewriting it. The widget in there at the moment is based on “best practices” for Android from 2013.