Blank graphs, not data shown as of 1pm today(Solved)

As of 1pm today no data is shown in any of the graphs or the maps. uninstalled, reinstalled. Same result. Main app screen showing no data. Widgets showing no data.

Changing sources shows a toast notification of "No valid forecast for ".

2 Likes

@mick Hello and Welcome to the Forum and Thank You for Using Flowx

1 Like

@mick I added the location in your photo no matter what model I chose the graphs all worked

1 Like

@mick just checking when you select the 3 dots top right then tap edit data did you select what data you want to see? if so try un-selecting all then re-select them too see if it works also try tap the 3 dots top right then tap refresh then tap the 3 dots and tap refresh again then tap force refresh. possibly try restarting your device

1 Like

Data is/was selected. See attached.

Unselected all - refreshed data (obviously no data shown) then selected some data again, refreshed same result (no data).

Hitting the refresh twice and so forcing a refresh, again no data. Changing the dropdown to another source, get the "No valid forecast for " toast notification.

Restarted device. Uninstalled and re-installed app.

2 Likes

Changed servers and now it works! Was set to closest (which is Frankfurt I think)

4 Likes

Frankfurt server is normally quite quick but seems to be misbehaving today.

2 Likes

@mick good glad it’s working that was going to be my next suggestion was to try different server. again glad it’s working

2 Likes

Widgets were not updating. Restarting phone and re-adding the widgets has fixed that.

2 Likes

Thanks to everybody for help.

2 Likes

@mick excellent :+1::+1:

2 Likes

Got the same problem… will try the steps here.

1 Like

Yes had to change server also to USA as Frankfurt is not working.

3 Likes

@Bades Hello and Welcome to the Forum and Thank You for Using Flowx

2 Likes

Awesome work debugging guys!! This is what I made the forum for.

You pretty much found the problem. Frankfurt server went down last night while I slept.

This happened to the forum and the New York servers yesterday. I’m not sure what caused it but restarting it seems to have fixed it.

Sorry about the problem.

Cheers, Duane.

3 Likes

Yes, the forum is working as intended! :sunglasses:

Here is a sugestion/question:

How about having the flowx app try another server if the server selected is not responding (properly) (for some defenition of propperly)?

Cheers!

1 Like

Yes I did briefly think of that but this kind of failure is the first I’ve seen so it’s very rare. So putting time into it might not be worth it.

The other thing is that it adds complexity which may lead to a more common bug. For example, the servers might be out of sync so when you switch to another server, the data might not exist there. It might be out of sync by a few seconds but when you have 80k user a month and servers syncing some 100 times a day, there a many chances of this causing a bug.

I think it’ll be better to have messaging in the app, reporting server status and checking downloads as they come in for corruption or incomplete downloads.

2 Likes

Yes, where to put the time is always an important question.
I trust your judgment, and I feel that I’m learning by reading your responses!

I feel that I must verry much show my appreciation for all the time that you take the time to explain that/why a question/sugestion is not the best to put time on.

And I’m completely with you an this one:

Did not think realize that “servers out of sync by a few seconds” could cause a problem, but that is of course a risk.

Keep it simple, as you so often say.

Cheers!