Can't Create Widget

Hello,

I have a Samsung Galaxy S8 Plus, with Android 9.0, and Flowx 3.346. After a long period of not using Flowx widgets, I tried to install one, but it won’t. I go to my list of widgets, then drag the Flowx widget to where I want it, but the Configure Widget screen never comes up. Instead, a blank screen comes up, and I eventually get an error message telling me that Flowx isn’t responding. I have cleared Flowx’s cache and data, then uninstalled Flowx, restarted my phone, and reinstalled Flowx, but I still get the same error message, that Flowx isn’t responding. I also have Flowx installed on my Samsung Tab S5e, with Android 11.0, and Flowx 3.346, and get the same results, when I try to install a Flowx widget. Doesn’t matter if I use the stock launcher or Nova. Having no problems installing widgets of other apps.

Thank you
Pedum

2 Likes

Sorry, I can’t help anymore with widgets. I’ve spent so much time on widgets and it’s been a right pain. Just search “widget” on the forum and you’ll see how much time it has taken.

The widget works on some phone but not on others. When I fix something on some phones, it breaks on others. It just doesn’t make sense.

Anyway, this widget code is over 8 years old and I think the best thing is to rewrite the widget from scratch. I’m currently rewriting the backend code and I’m hoping this will replace all the old code.

Cheers, Duane.

3 Likes

@Pedum try cleaning app cache and clearing app data you will have to reset up Flowx unless you export settings hope it helps

1 Like

Actually, I saw the Crash/ANR reports this morning. It doesn’t look like the issue I was thinking.

Can you try opening the app, set the data source to GFS and then try and add a widget?

Let me know if that works or not.

2 Likes

Just a note, clearing the app data pretty much like reinstalling the app.

3 Likes

After saying I can’t help, I’ve found the bug and fixed it. I thought it was theme/OS related but this was to do with a unique sets of conditions. You had to be in the USA so your first location was somewhere in the USA, be a Gold subscriber, open the app, turn on HRRR and then add a widget.

Release 3.348 will be out in the next few hours with the fix.

3 Likes

BTW @Pedum, it was because of your persistent trying and reinstalls that the crash log got inundated with the same crash bug that I noticed. Also it showed that the bug was able to be replicated if we knew the condition to replicate it.

3 Likes

Yes, I am in the USA, I am a Gold subscriber, was using HRRR in the widget, etc.

Thank goodness for crash logs. :slightly_smiling_face:

I have downloaded, and installed 3.348. So far widgets appear to be working correctly.

Thank you Duane.

pedum

2 Likes