No radar data

I got a new phone (Samsung, Android 13, OneUI 5.1) a few weeks ago, and Flowx (Release 3.400) has been running fine. Until yesterday. Suddenly I get no radar data. I have tried to clear the cache, enabled/disabled radar reflectivity, switching servers, manual refresh, reboot, … but nothing helps.
I thought it could be a server issue, but everything works fine on my old phone (Samsung, Android 12, OneUI 4.1).

Any idea?


If I go to another location - far away from my home location (e.g. in Asia), I get radar data also on the new phone …


Welcome to the world of software and internet connectivity. It’s lucky you have two phones. In most cases, there is only one phone and users assume the issue is not localized to the phone. Most causes of issues like this is network connectivity.

Can you turn on “debug” mode in settings, then email me the debug log via Feedback in the side menu?

Can you try clicking refresh twice to force a download?

If that doesn’t work, can you also try forcing a download on the mobile network?

Then email me the debug log again?

Hopefully we can find some hints in the logs.

Cheers, Duane.


Thanks for quick feedback.
I followed you instructions and emailed the log.

The interesting part is that with debug on and forced download, I got the radar data …


It wasn’t due to “debug” mode being on. All this does is record more debugging details.

The force download would’ve downloaded the visible data again from scratch. I suspect there was a corrupted download. It might be coincidence that it happened twice the new phone or maybe the new phone is dropping or switching networks more often??

I plan to add more checks to check the validity of data in the future.


Thanks again.

Seems to be updating fine now …


@helsten2 Hello and Welcome to the Forum and Thank You for Using Flowx


In this case I do believe you. Probably a corrupted download, and then a forced download does the trick.

But fun fact: once I was working on a project where a bug happened, but only when "debug” mode was on. It turned out that the write speed to disk (SD cards on early Rpi) was the limiting factor, and the added data from the "debug” mode made a critical difference.

I seldom do this, but often “clear” the app, by not just “closing” it, but also swiping it away from the list off apps running in background, and then restarting the app by tapping widget.

In my experience, this downloads what is missing, and it is faster than “clicking refresh twice”, and it have the added bonus of instantly moving the the time to “now”.

Otherwise when re-opening Flowx that have been “on” in the background, the time shown is in the past.

1 Like

I’ll give that a try. Thanks.

Double refreshing is so tedious. :grinning:


EDIT: Sorry, I was to fast. Problem is solved by following the steps. Wasn’t paying attention enough myself.
Keep up the good work. Very happy with the app anyway. Best weather app I know. As I travel around western Europe a lot)


I noticed this “bug” as well (always late, I know) and followed all the steps given. It didn’t help. Any further suggestions are welcome.
I’m working with a Pixel 6 on Android 13. No extra shells.

Thanks in advance.

(if you need any extra info. Please let me know)


I’ve still the problem - No Radar.
Double click on update will not help

I’m working with a Pixel 6 on Android 13.

Any Idea?


@gegges11 Hello and Welcome to the Forum and Thank You for Using Flowx. So force refresh didn’t help? might try a couple things 1st might try changing servers from new York to Germany or visa versa 2nd might try exporting your settings/setup then try deleting app data 3rd might try deleting app and re-installing But make sure you have debug logging on incase nothing works

1 Like

Also for RainViewer info to show you need to make sure you have place data set to a minimum of -1 to however many days you want

1 Like

Can you send a screenshot please? It could be a different problem.


thx’s for your quick response.
nothing will help. I change the server and force a new update, I reinstalled the app from scratch without export and import the config. The screenshot is attached time is today 16.34 staying at Berlin


You don’t have radar selected. The first icon is precipitation. The last icon is radar. I would suggest turning off precipitation and turning on radar.


Oh,what a foolishness. thx’s