Widget not showing all weather providers(Fixed)

Hi, and happy Easter.

I seem to have a bug with my widgets. The app shoes 10 different weather providers as I would expect.

The widget shows 3.

I have uninstalled and reinstalled, and due to unrelated issues reformed my phone, but I cannot get more than 3 options for the widget.

See screenshots

Many suggestions?

Thanks for any help

2 Likes

@Kai666 odd it’s working for me

2 Likes

It could perhaps be related to the location.

When you re-install the app, and then import a “travel mode” location, the app has yet not gotten GPS permission.

Try toggle the “travel mode” off, then on again in the “Edit place” menu, in order to get the pop up asking for GPS-permission.

Perhaps there is a difference in how the app and the widget handle these cases.

2 Likes

Hi,

Try what @Ohan said. The data sources you see depend on the location.

There may be a bug. If we try some other configurations, then we’ll have more info.

Cheers, Duane.

2 Likes

Thanks for the suggestions. They made no difference still only get the 3.

The strange thing is it’s a German weather provider, I’m in the UK so there are other closer providers, but they don’t show up.

2 Likes

try different provider

1 Like

@Kai666 Try this, please. Instead of using “My Location”, put the name of your town in that option and see what that does. Hopefully, your town is large enough to appear on the list.

1 Like

OK, so put my exact location in (an area of london) rather than travel mode.

Still only gave me the 2 default providers and DWD ICON😕

2 Likes

I’ll have a look into this today. Can you email me the debug log via feedback?

2 Likes

I’m planning a release today so if you can get the be debug log soon, then I can debug this and include it in the release.

2 Likes

Sent.

Thank you so much

2 Likes

Your first location is defaulting to 0 latitude and 0 longitude when you turn on Travel Mode. This means it’s not getting the location from your GPS. Have you got location permissions on? Check Android Settings > Apps > Flowx > Permissions.

2 Likes

Hi @Kai666.
Does the issue persist for you?

Really sorry, I’ve been busy and completely forgot to update on here.

Yes all is working fine now. Thank you Duane for your hard work

3 Likes

Glad to hear that!

@duane is the man for the job!
Cheers!