Pro Versions Not Recognized [Answered]

Aware of and Answered

4 Likes

I also reported on this issue two weeks ago, referencing a Pixel 3 which had this problem. There I mentioned that I also have a Samsung tablet and a Xiaomi phone, that both of them didn’t have the issue.

Now it turns out that v3.350 caused me to drop out of Gold status on that Xiaomi phone, so it is a different problem than before, but somehow more serious because when I restart the app, I only have the option to buy Gold status again if I want to use it. Neither the Samsung tablet nor the Pixel phone show this problem on this new v3.350.

Sending the log via email.

The odd thing is that the log shows that the app receives a notification from Google that Gold status is active:

[DataService state] DownloadQueue has 0 entries
[DataService state] DownloadService is null
05 08:41:28.602: [ProAssets] Products silver_999_v2 : 9,99 € EUR
05 08:41:28.602: [ProAssets] Products bronze_499_v01 : 4,99 € EUR
05 08:41:28.603: [ProAssets] Products gold_1999_v2 : 18,99 € EUR
05 08:41:28.603: [ProAssets] History gold_1999_v2 : GPA.3[---REDACTED---]8 (t=1567887980487, state=1)

When I click on buy and check which payment options I have, it shows me the options from one of the google accounts which I didn’t use to buy this app. So if I bought it via email1@gmail.com, it is attempting to buy it via email2@gmail.com.

Somehow it is defaulting to the wrong address for the purchase check, but the logs show that the information of the purchase is there.

1 Like

Sound like this problem:
https://flowx.io/help/why-is-my-pro-subscription-not-working/

Can you check if it’s the multi-Google account problem?

2 Likes

Hi Duane,

I did send you the log of the Xiaomi device back then. In the linked page you say that

“Sorry about this problem. I would rather not have it but I cannot do much about it.”

But as I said, the logs do contain a string which indicates that the app is capable of receiving the purchase information (05 08:41:28.603: [ProAssets] History gold_1999_v2 : GPA.3[---REDACTED---]8 (t=1567887980487, state=1)). What does this line mean? I mean, the GPA.3[…]8 is what I find in the purchase confirmation email sent to me from Google.

I’m really unwilling to uninstall the app, since setting it up again is not really fun, as some little things don’t seem to get stored in the Export (like the positioning of the icons in the bottom). And I’m even less inclined to remove accounts from my phone. I hope you can understand this.

1 Like

I added that as a debug history. It recognised your purchase via the primary account in the past but not with the current primary account.

I have tried to write code to keep my own history and use that but it’s damn difficult and add bugs. I have to write code to recognise trial periods, when things expire and if someone cancels, I won’t know.

Although Google is looking at this issue now, I’m really disappointed in Google, they do things like revamp the Developers console, add Bundles, change all sorts of features but now they own the developers (i.e., we have nowhere else to go) they are slow at listening to real problems.

Sorry I won’t implement features that already exist in Google Play since it’s a massive job and all it takes is Google Play adding a feature to check all accounts on the phone.

Honestly, I have tried to tackle this problem many times.

Here is a link to the latest bug tracker:
https://issuetracker.google.com/issues/139597485?pli=1

Notice how many developers are in the same boat. It’s sad and frustrating. Feel free to add your comment as an app user - it might add a spark they might notice. I plan to post again.

1 Like

Ok.

I uninstalled it. Went to play.google.com on my PC with the account which has a license, went to flowx ( https://play.google.com/store/apps/details?id=com.enzuredigital.weatherbomb ) and triggered a remote install from there.

The app is now licensed again.

I was unable to export to the local device, I always got write permission denied after selecting the location Solid Explorer as well as ES File Explorer, I had to upload it with the Google Drive app to my Google account. Google File app was installed, but not offered as a directory selector for export, even though it does seem to be used for imports. I was able to import via Google Drive from the account.

My Dark Theme selection was lost, not dramatic, the server had to be re-selected (I’m not using “nearest” but Frankfurt, ,even if it is the nearest), and the icon/features selection wasn’t in the export, had to be readjusted.

This is OK, it’s not much work. But I just hope that this doesn’t happen as often as it did back then (2 years ago?).

But it still is an excellent app, I can’t imagine how much work it has to be to manage all the data sources on the backend.

1 Like

Android keeps changing and I can’t keep up with the OS, for example, I don’t have Android 12, so I can’t be testing those new features. Android keeps improving battery optimization and privacy for users but makes it difficult for developers to keep up. I’m hoping the rewrite I’m currently doing will bring everything up-to-date and get rid of some old stuff.

Managing the data sources is relatively easy since I’m in full control of my processing scripts and servers.

3 Likes

Duane, good luck with it and don’t lose your motivation. Regarding new Android version it’s always helpful to use an emulator to do some quick checking. I know that a lot of stuff is not really working on an emulator, mostly Google Play related stuff, but oftentimes it gives you a good feeling about how things mostly regarding privacy are changing (which are some of the hardest thing to deal with).

3 Likes